helloworld build error


Zhao, Xiaonan <xiaonan.zhao@...>
 

Hi, dear all,

 

Test environment:

SGX PSW: Intel(R)_SGX_Windows_x64_PSW_2.7.100.2.exe,

SGX SDK: open-enclave.0.8.2.nupkg, installed path: C:\openenclave

cmake version 3.16.19112601-MSVC_2

 

When build helloworld project, met following errors, how to solve it?

 

******************************************************************************************

 

CMake Error at CMakeLists.txt:15 (find_package):

  Could not find a configuration file for package "OpenEnclave" that is

  compatible with requested version "".

 

  The following configuration files were considered but not accepted:

 

    C:/openenclave/lib/openenclave/cmake/openenclave-config.cmake, version: 0.8.2 (64bit)

 

 

 

-- Configuring incomplete, errors occurred!

See also "C:/openenclave/share/openenclave/samples/helloworld/build/CMakeFiles/CMakeOutput.log".

 

******************************************************************************************

 

 

 

Thank you,

Xiaonan

 


Ming-Wei Shih
 

This is likely due to the environment variable is not set. Can you follow the instruction here: https://github.com/openenclave/openenclave/blob/master/docs/GettingStartedDocs/Windows_using_oe_sdk.md#configure-environment-variables-for-open-enclave-sdk-for-windows?

Thanks,
Ming-Wei

From: oesdk@lists.confidentialcomputing.io <oesdk@lists.confidentialcomputing.io> On Behalf Of Zhao, Xiaonan via lists.confidentialcomputing.io
Sent: Friday, April 10, 2020 12:24 AM
To: oesdk@lists.confidentialcomputing.io
Subject: [EXTERNAL] [oesdk] helloworld build error

Hi, dear all,

Test environment:
SGX PSW: Intel(R)_SGX_Windows_x64_PSW_2.7.100.2.exe,
SGX SDK: open-enclave.0.8.2.nupkg, installed path: C:\openenclave
cmake version 3.16.19112601-MSVC_2

When build helloworld project, met following errors, how to solve it?

******************************************************************************************

CMake Error at CMakeLists.txt:15 (find_package):
Could not find a configuration file for package "OpenEnclave" that is
compatible with requested version "".

The following configuration files were considered but not accepted:

C:/openenclave/lib/openenclave/cmake/openenclave-config.cmake, version: 0.8.2 (64bit)



-- Configuring incomplete, errors occurred!
See also "C:/openenclave/share/openenclave/samples/helloworld/build/CMakeFiles/CMakeOutput.log".

******************************************************************************************



Thank you,
Xiaonan


Jordan Hand
 

Hi Xiaonon,

If you are still experiencing this problem would you be able to open an issue on our github repository: https://github.com/openenclave/openenclave/issues

This will help us better triage the issue and help you solve it.

Thanks!
Jordan

________________________________
From: oesdk@lists.confidentialcomputing.io <oesdk@lists.confidentialcomputing.io> on behalf of Zhao, Xiaonan via lists.confidentialcomputing.io <xiaonan.zhao=intel.com@lists.confidentialcomputing.io>
Sent: Friday, April 10, 2020 12:24 AM
To: oesdk@lists.confidentialcomputing.io <oesdk@lists.confidentialcomputing.io>
Subject: [EXTERNAL] [oesdk] helloworld build error


Hi, dear all,



Test environment:

SGX PSW: Intel(R)_SGX_Windows_x64_PSW_2.7.100.2.exe,

SGX SDK: open-enclave.0.8.2.nupkg, installed path: C:\openenclave

cmake version 3.16.19112601-MSVC_2



When build helloworld project, met following errors, how to solve it?



******************************************************************************************



CMake Error at CMakeLists.txt:15 (find_package):

Could not find a configuration file for package "OpenEnclave" that is

compatible with requested version "".



The following configuration files were considered but not accepted:



C:/openenclave/lib/openenclave/cmake/openenclave-config.cmake, version: 0.8.2 (64bit)







-- Configuring incomplete, errors occurred!

See also "C:/openenclave/share/openenclave/samples/helloworld/build/CMakeFiles/CMakeOutput.log".



******************************************************************************************







Thank you,

Xiaonan


Zhao, Xiaonan <xiaonan.zhao@...>
 

I followed that wiki step by step, OE is installed in c:/openenclave, and cmake is in c:/openenclave/lib/openenclave/cmake.

 

Are there any causes of this error?

 

 

From: Ming-Wei Shih <mishih@...>
Sent: Saturday, April 11, 2020 12:55 AM
To: oesdk@...; Zhao, Xiaonan <xiaonan.zhao@...>
Subject: RE: helloworld build error

 

This is likely due to the environment variable is not set. Can you follow the instruction here: https://github.com/openenclave/openenclave/blob/master/docs/GettingStartedDocs/Windows_using_oe_sdk.md#configure-environment-variables-for-open-enclave-sdk-for-windows?

 

Thanks,

Ming-Wei

 

From: oesdk@... <oesdk@...> On Behalf Of Zhao, Xiaonan via lists.confidentialcomputing.io
Sent: Friday, April 10, 2020 12:24 AM
To: oesdk@...
Subject: [EXTERNAL] [oesdk] helloworld build error

 

Hi, dear all,

 

Test environment:

SGX PSW: Intel(R)_SGX_Windows_x64_PSW_2.7.100.2.exe,

SGX SDK: open-enclave.0.8.2.nupkg, installed path: C:\openenclave

cmake version 3.16.19112601-MSVC_2

 

When build helloworld project, met following errors, how to solve it?

 

******************************************************************************************

 

CMake Error at CMakeLists.txt:15 (find_package):

  Could not find a configuration file for package "OpenEnclave" that is

  compatible with requested version "".

 

  The following configuration files were considered but not accepted:

 

    C:/openenclave/lib/openenclave/cmake/openenclave-config.cmake, version: 0.8.2 (64bit)

 

 

 

-- Configuring incomplete, errors occurred!

See also "C:/openenclave/share/openenclave/samples/helloworld/build/CMakeFiles/CMakeOutput.log".

 

******************************************************************************************

 

 

 

Thank you,

Xiaonan

 


Simon Leet
 

Hi Xiaonan,

Your mail doesn't really contain enough information for us to help troubleshoot this, but the end result looks very similar to https://github.com/openenclave/openenclave/issues/2849. Can you ensure that you're running the x64 version of the Build Tools Command prompt?

If you are seeing a different error, can you file an issue with your detailed errors at https://github.com/openenclave/openenclave/issues?

Thanks,
Simon